AWS has resolved their underlying issue which has allowed us to provision additional servers. We have now restored all traffic to the normal server groups and are no longer seeing latency in provisioning servers. We will continue to monitor the situation
Posted Jan 28, 2026 - 19:26 UTC
Identified
We are currently affected by an AWS incident in the EU-WEST-1 region which is restricting our ability to provision additional servers. Efforts are being made to redirect traffic to unaffected server groups while the issue is resolved
Posted Jan 28, 2026 - 18:39 UTC
Investigating
We are currently investigating an issue affecting service health. Updates to follow
Posted Jan 28, 2026 - 18:18 UTC
This incident affected: Web Interface, Mobile Applications, and POS Integrations.